Zensur!

bloggbox: Zensur!
flickr sperrt uns aus! Und auch dich!
Seit gestern werden für deutsche Nutzer keine Bilder mehr angezeigt, die als ‘moderate’ oder ‘restricted’ markiert sind! Es gibt keine Moeglichkeit das umzustellen – das ist eine grobe Unverschämtheit und Frechheit von flickr!

In English:
If your Yahoo! ID is based in Singapore, Germany, Hong Kong or Korea you will only be able to view safe content based on your local Terms of Service so won’t be able to turn SafeSearch off.
In other words that means, that german users can not access photos on flickr that are not flaged “safe” … only flowers and landscapes for the germans …
We will not let this happen! Copy and upload this picture to your account – show flickr who we are!

Lade dieses Bild runter und poste es in deinem Account! Lass uns das Bild überall auf flickr verteilen und es in ‘Interestingness’ heben!! So geht es nicht!

Ich blogge wieder, oder: WordPress und PHP 5.2.2

Okay, nachdem die ebenso eifrigen wie sicherheitsfanatischen Jungs von schokokeks.org ihre(n) Server auf die neueste Version von PHP 5.2.2 aktualisiert hatten, konnte ich meine üblichen Hilfsmittel zum Bloggen nicht mehr verwenden, weil die Kommunikation mittels XML-RPC nicht mehr funktionierte. Fluch des frühen Updates. Nachdem ich heute endlich mal die Muße hatte, mich selbst darum zu kümmern und vom Keks-Support einen entsprechenden Hinweis bekam, war das Problem dann sehr schnell gelöst:

Folgende Zeile vor der ersten IF-Abfrage in WordPress’ xmlrpc.php einfügen:

$HTTP_RAW_POST_DATA = file_get_contents("php://input");

Danach klappt’s auch wieder mit WordPress und (z.B.) RapidMetaBlog.